Tractor Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a t4,5. thru the serpentine belt and it destroyed my wiring harness and broke the radiator hose. Any have this problem before and is it an issue?
 

·
Registered
Joined
·
3,329 Posts
Welcome to the forum.

Sounds to me like your serpentine belt was fraying before ultimate failure. Check the bearings in your idler and tensioner pulleys. One may have frozen to cause this problem. It may also be bearings going out in the driven components...alternator, water pump, AC unit?, etc. In view of the damage caused, I would replace the idler/tensioner pulley bearings before installing a new belt as a preventative measure.
 

·
Banned
Joined
·
3,188 Posts
Serpentine belts are very sensitive to tracking issues and must be closely aligned to the various sheaves they wrap around as well as continuous tension. Like Big T stated, check all the sheaves and the spring loaded tensioner before putting on a new belt.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
thanks for the suggestions. planned on replacing all, main question is the problem with it destroying wiring harness. seems to me like bad design or is this a common problem with these tractors? thank you
 

·
Registered
Joined
·
3,329 Posts
Serpentine belts are extremely strong. I suppose that when the serpentine belt starts to shred, it is tougher than a weedwhacker, if you don't catch it right away. You must inspect the belt for wear as part of your routine checks. I would put metal sheathing around the radiator hose and wiring harness to prevent this from happening again.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top