Tractor Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
I have a CK 2610 drove it back to the shed last night.
I think it's a 2017, with 550 hours on it.
Stopped and shut it off to take off a trailer.
Went to start it up, and I saw a flash of light. It was dusk.
After that, it would not start. When you turn the key, there is a buzzing
sound around the dash, and the dash lights go nuts.

What is the world is this about?
I need quick help because it's blocking a car we need to use. :)
Thanks
 

·
Administrator
Joined
·
11,185 Posts
I have a CK 2610 drove it back to the shed last night.
I think it's a 2017, with 550 hours on it.
Stopped and shut it off to take off a trailer.
Went to start it up, and I saw a flash of light. It was dusk.
After that, it would not start. When you turn the key, there is a buzzing
sound around the dash, and the dash lights go nuts.

What is the world is this about?
I need quick help because it's blocking a car we need to use. :)
Thanks
Good morning! Hard to diagnose what the actual issue is, but sounds electrical. How about disconnecting the battery for a few minutes to let things "Reset" so to speak. Check the battery voltage while you are at it and make sure all you safeties are dealt with... ie: PTO off, seat switch working, brake on and in neutral. worth a shot.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #3 ·
Good morning! Hard to diagnose what the actual issue is, but sounds electrical. How about disconnecting the battery for a few minutes to let things "Reset" so to speak. Check the battery voltage while you are at it and make sure all you safeties are dealt with... ie: PTO off, seat switch working, brake on and in neutral. worth a shot.
You're correct, and I'm sure it's electrical. I don't live on the land where the tractor is, so I will try all the suggestions I get a little later.

Disconnect the battery.
Check the battery voltage.
It is in neutral. I have to push in the clutch to start, no matter what gear it's in.
No seat switch. My last Kioti had that. I hated it and disconnected it. :)
The brake is on.

I was wondering if the flash I saw was a relay or a fuse popping?

Thanks, I will let you know later today.

If anybody else has an idea, please let me know. Thanks
 

·
Registered
Joined
·
1,508 Posts
Does not sound like a fuse if you saw a flash.....Sounds to me like a hot wire arced to ground......I would check your wires and connections from the positive battery terminal to the starter.......I am going to guess that you have either a loose connection at the battery or at the starter.......
 

·
Registered
Joined
·
15 Posts
Thanks, the battery connections are clean.
I'll check the solenoid.
Clean means remove and clean, not just eyeball. Battery posts, positive connections at starter solenoid Especially the ground connections. Remove all and clean.
Your description of the chattering around the dash sounds like a relay trying to energize with low voltage, ie: bad battery connections somewhere. :cool: OT
 
1 - 8 of 8 Posts
Top