Tractor Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Change hst filter. Ran tractor no problems. Next day started digging with backhoe and went to load front bucket with dirt. Lost power to rear drive wheels. No forward or reverse. All other hydraulics work. Hoe bucket. Do I need to bleed system after hst filter change?
 

·
Registered
Joined
·
2,339 Posts
Good Morning Topcat, welcome to the forum.

Have you checked the hydrostat reservoir fluid level? I would jack up the rear wheels (make sure the FWD is disengaged, if applicable), and try to get the rear wheels turning to purge the system.

Does your tractor have a traction disconnect for moving it by hand? Maybe it's disconnected?
 

·
Registered
Joined
·
128 Posts
I don't know of any newer HST drive tractors that require bleeding of the system after fluid and or filter change.....I had the reverse problem with the Kioti CS2410 that I used to have after a filter change. Mine would drive but I had no hydros to the FEL or the 3 point. I called my local dealer and he told me to look in the manual and see hold long they recommended to run the tractor after a filter change. I looked it up and it said after a filter change to run the tractor at ( I don't remember what RPM) for I think it was 15 to 20 minutes before using it. I did this and it took care of the problem. Might check the manual and see if LS has the same type deal as Kioti does....Or just call the local dealer and ask someone in the service department if they have ever came across this problem.
 
1 - 5 of 5 Posts
Top