kubota hydraulic problem solved

Discussion in 'Kubota' started by DP50, Sep 13, 2009.

  1. DP50

    DP50 New Member

    4
    Sep 10, 2009
    Hi All, A few days ago I posted a problem with my L245DT the loader and 3 pt would barley raise and only at high R's with no lift strength.after checking everthing I could take apart I was only able to find the one relief valve under the seat at pressure block, It looked as though the pump needed to be replaced after reading the function of the loader control valve it said that near the inlet valve there is a relief cartdiage sure enough a small piece of gunk had stuck this valve partialy open, by pushing down with a small bolt it broke free and move freely aginst the spring load screwed it back in and to my relief the relief worked and all was back to normal wanted to post this incase any one else should have this problem. Thank you all for your input on my original post the good thing is the filter got cleaned do to this good luck on all your repairs out there!
     
  2. Live Oak

    Live Oak New Member

    Dec 21, 2003
    Glad you figured out what the problem was DP50. Did you receive the Kubota parts manual I emailed you? What did the piece of gunk look like? Was is just crud or a peice of plastic or metal?
     

  3. DP50

    DP50 New Member

    4
    Sep 10, 2009
    stuck valve

    thanks I did get the manual that was great, the stuck valve was a piece of crud the filter was a nasty mess may have come from there. The tractor was my niehbors, her husband died 9 years ago and other than some use here and there by me on both are places it has sat,only2107 hours on her, she remarried and her and terry have no Idea how to use it so she sold it to me with the tiller and brush hog for $1300 that way she can still have me do a few things for them every now and then a deal i could not refuse! Replacing rear wheel seal this week as well as fluids tractor still runs great and it likes working agian makes a good addition to my early forty's cable blade D7 thanks agian for the help!
     
  4. CT18fireman

    CT18fireman New Member

    2
    Apr 6, 2010
    Where exactly did you find this valve? By the loader control? I just developed a simliar problem in that my loader as no power. Hoping to get into it tomorrow to check things out.
     
  5. compgeek

    compgeek New Member

    6
    Apr 19, 2011
    I was wondering the same thing..

    I posted in the Kubota section of the big tractor forum..under buddy needs some help....I have some pics there to..it's a L3710 model.
     
  6. omszee

    omszee New Member

    6
    Sep 27, 2011
    hi guys i just recently cleaned and service my position valve,and relief valve, i also re bushed the hydraulic lift arm housing, it was badly damage of neglect from the pass owner. my problem is, is their a special way that the lift arm fits onto the hydraulic arm shaft ?? and how do i re connect the Feedback Rod??? please any information will be of great help.....
     
  7. AshleyBS55

    AshleyBS55 AshleyBS55

    2
    Jul 31, 2012
    Is this the relief valve shown here in the picture? I'm having the same problem, but am not sure if this is the releif valve. Thanks
     

    Attached Files:

  8. needafix1

    needafix1 New Member

    1
    Nov 20, 2013
    I have a Kubota L3240, the front end loader works fine, but the rear lift arms will not move up or down--just quit for no apparent reason. Need help troubleshooting?
     
  9. nearmoon

    nearmoon New Member

    1
    Nov 23, 2013
    i have l39 and im missing hydraulic power , i changed the pump and still front loader and rear arm dont have power at all. Does anyone know what else the problem could be also can the hydralic system have air in its stream if so what may be the problems thanks!!
     
  10. lucerne

    lucerne New Member

    1
    Apr 28, 2015
    My kuboto L39 has no power in the bucket or the back hoe
     
  11. Micademan

    Micademan New Member

    1
    May 23, 2015
    Did you ever find a solution? I have the same problem with my B3030.
     
  12. Icebox

    Icebox New Member

    2
    Oct 28, 2015
    I have a B7200 and was getting hydraulic oil in the engine plus weak FEL. Replaced the Pump and fixed bypass leaking but FEL still Slow and Weak to lift but 3 Pt works fine. Any ideas ??
     
  13. Icebox

    Icebox New Member

    2
    Oct 28, 2015
    A little history oF my adventure. Suspected Hydraulic oil bypassing into engine by checking fluid colours and levels.
    Changed all Oils, both filters, cleaned screens (2). Bucket worked great for an hour or so then started to slow and not lift much weight.
    Rebuilt pump with O rings and seal, a little better but got even worse than before.
    Replaced Pump ( that cured bypass problem ) 3 PT still OK but bucket slow to lift light load. Checked Relief cartridge in Control but that's as far as I've gotten....... FEL still slow and weak.
     
  14. birdman

    birdman New Member

    1
    May 10, 2017
    I have a Kabota bx 25d. I was removing a tree from off a fence. With the bucket up high I clipped a small tree in reverse. Hydraulics to front bucket will not lift. Any help will be greatly appreciated. Unfortunately I reversed it into the shed. Now I cannot remove the Backhoe in order to check the inlet valve on rear of tractor. Have checked hydraulic lines to the bucket. There appears to be no hydraulic fluid leak. I did have the presence of mind to put small object under bucket before it sagged to ground.
    Any help will be greatly appreciated Nick
     
    Last edited: May 12, 2017
  15. rhino

    rhino Registered User

    45
    Jan 9, 2017
    Check and make sure that all the quick couplers are together. Some times they get hit and come apart, but look like they are together.
     
  16. jp3088

    jp3088 New Member

    2
    May 24, 2017
    i have a svo-5 skid steer left and right function not working all other functions ok but sluggish help