Tractor Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I have a international 330 that keeps pushing the hydraulic pump seal out and filling crank case with oil, the pressure relief seems to be working, it pushes it out at about half throttle, this is the fourth one. Any help would be appreciated.
IH330.jpg
IH330hyd.jpg
IH330pump.jpg
IH330pump.jpg
 

Attachments

·
Registered User
Joined
·
252 Posts
I don't recall the exact pressure those hydraulics ran at but it was fairly low,
I'm thinking 1200 to 1500 PSI max.
If you are in that range and shoving the seal out it could be wear in the shaft bushing or the seal is just not tight enough, could use a bit of lock tite on the seal.
Nice looking IH.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
I don't recall the exact pressure those hydraulics ran at but it was fairly low,
I'm thinking 1200 to 1500 PSI max.
If you are in that range and shoving the seal out it could be wear in the shaft bushing or the seal is just not tight enough, could use a bit of lock tite on the seal.
Nice looking IH.
I don't recall the exact pressure those hydraulics ran at but it was fairly low,
I'm thinking 1200 to 1500 PSI max.
If you are in that range and shoving the seal out it could be wear in the shaft bushing or the seal is just not tight enough, could use a bit of lock tite on the seal.
Nice looking IH.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #4 ·
I am beginning to think that there really shouldn't be any pressure on that seal, but for some reason there is. I had to use press to put seal in, it was very tight. The first two seals blew the rubber out so I went with CR seals and now they just push the whole seal out. It was working fine before restore but it was 7 years working on it in my spare time, I'm beginning to think the pump is wore enough to cause the problem. Thank you.
 
1 - 8 of 8 Posts
Top