Tractor Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hello all,

First time posting, hoping to get some troubleshooting help with the digital tach on my 1586.

It is the style with the multiple push buttons. Right now the digital display works, and all the buttons work. However, the readouts are not right, for instance the tach reads 380 all the time, ground speed reads 2, pto reads 280 (changes occasionally) even when pto is not engaged.
I'm hoping this is a connection issue, but really don't know where to start.

Probably unrelated, but the battery gauge only works when tapped on, and the fuel gauge doesn't work.

Any help is appreciated, thanks in advance!
 

·
Premium Member
Joined
·
2,675 Posts
I suspect your best bet if you want to keep the original style instrument cluster is to locate a rebuilt or good used assembly. They eventually fall to the ravages of time and humidity in the cab.

You may want to try: Case IH - the IH 3688 panel interchanges and some NOS units may still be available, www.batescorp.com, a salvage yard, or Ebay.
 

·
Premium Member
Joined
·
2,675 Posts
The internal contacts are more than likely corroded given you are getting some gauge registration and tapping results in the battery gauge working. You can remove the panel and cluster and try cleaning the main connectors and the internal contacts, and then spray them with an electrical contact cleaner and anti-corrosion compound. See if that brings all of the gauges back to life.

Clean your fuse connectors in the fuse panel too.

The fuel sensor in the tank may have failed, but I would start with the cluster first and work out from there.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
Sorry one more question. Is there an option to change to a different style gauge? I'm mainly worried about getting a working tach, the others are just a bonus?
 

·
Premium Member
Joined
·
2,675 Posts
1 - 6 of 6 Posts
Top