Tractor Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello everyone, I'm new to this form and still trying to figure out exactly how it works, anyways long story short I purchased a tractor about a year ago it's a Ford 4000 with skip loader, not sure of the exact year but when I resealed the injection pump it had 1962 stamped on the inside so I'm assuming that's the year of it, basically the injection pump was leaking and the tractor wasn't running very good like it used to, after reading some forms online I decided it was a good idea to reseal it, I got it back on the tractor and all hooked up, its not leaking anymore but I am having a problem getting fuel to the injectors I tried cracking the lines open slightly at the injectors and cranking it until the battery died three or four times with the jump box on and still nothing, the fuel tank is about half full, and I know fuel is flowing because I can check at the screw on top of the fuel filter, so my question is maybe I resealed the pump incorrectly, or is there something I'm missing, could it possibly be that the plungers are not good anymore, but the tractor was running before so I'm kind of lost also I'm new to diesels and this is the first one I've ever owned and still trying to learn, also I tried uploading some pictures from the pump I took as I was rebuilding it, any help would be great thanks in advance
 

Attachments

·
Registered
Joined
·
1,085 Posts
Welcome to the Forum. Please post photos in the Tractor section.

You need to contact thepumpguysc directy to answer all your questions concerning injection oumps. His email is [email protected]. you can look up his profile under the Members section of the Forum. Do a name search.
 
1 - 2 of 2 Posts
Top