Tractor Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Lift arms do not respond smoothly when moving control lever in small increments.
i.e. move the control lever slowly and no movement of lift arms occurs until approx. 1/4" to 5/16" of lever movement as measured at the quadrant . Then the lift arms move to that position like 1/4" to 5/16" steps. If the control lever is moved to the full up position initially, the arms go to that position smoothly and also lower smoothly and in small increments if desired. It's as if a valve was sticking each time a raising movement is selected. There is no hiccuping? as I understand the reference and no bobbing up and down of the arms. Any thoughts are appreciated. This is a 1971 model but new to me.
l
 

·
Registered
Joined
·
2,332 Posts
Howdy Mowingman, welcome to the tractor forum.

For a 50 year old tractor, it sounds like it is working fairly well. What are you trying to do with such intricate movements??
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
Big T. Not too intricate, just finer adjustments of a 7" grader blade which previously I had mounted on a 1958 Ford WorkMaster for 30+ years and that lift system worked smooth as silk. With proper maintenance and or repair I expect better of the 3000.
The previously described issue actually causes the blade to move in increments of 2" to 3"which is unacceptable. I posted here with hopes another may recognize the symptoms and have some insight.
 
1 - 4 of 4 Posts
Top