Tractor Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I guys, looking for some help please. Working on a 1720. I changed the fuel filter and had trouble starting. I cracked the injector lines at the injectors until flow. Cylinders 2 and 3 were good, now flow out of #3. It did start, no power due to running on 2 cylinders. I was hoping under pressure it would start flowing. All of a sudden a large “plug” of oil shot out the overflow. Immediately shutdown. So maybe running 2 minutes total . I checked the oil that was free flowing out the dipstick. Very water like and smells like fuel in the oil. I had just changed the oil too, ugh. Bad injector pump, clogged line, or what? Not sure where to start.

the old fuel filter was bad shape.

thanks in advance guys,,
 

·
Registered User
Joined
·
123 Posts
Wow. You had to dump a lot of fuel into the crankcase. I can't imagine that much coming through the pump. Did you check the fuel level in your tank after this happened?
 

·
Registered
Joined
·
2,332 Posts
Howdy Chris, welcome to the tractor forum.

Sounds like the shaft seal on your injection pump is leaking diesel into the crankcase. Plus not injecting fuel into one cylinder? Time to service the injection pump.
 

·
Premium Member
Joined
·
1,553 Posts
Did u loosen the lines AT THE PUMP on #3.?? To find out if the pump was indeed pumping but the injector had blown a tip.
It does sound like a pump problem tho..
Not pumping on 3 AND filling the engine w fuel.. I think u found you problem..
If u would like to contact me directly, click on my screen name on the left hand side of the screen & go to profile..
 

·
Premium Member
Joined
·
3,469 Posts
Hello Chris,

Apparently there are two versions of injection pump for your tractor. Please post the data plate numbers from your injection pump.

Also, please review your original post, and clarify which cylinders are OK, and which one is bad.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #6 ·
Howdy Chris, welcome to the tractor forum.

Sounds like the shaft seal on your injection pump is leaking diesel into the crankcase. Plus not injecting fuel into one cylinder? Time to service the injection pump.
thanks. I pulled the lines off the pump this evening and little to no flow. Sounds like time to rebuild. Thanks
 

·
Registered
Joined
·
10 Posts
I guys, looking for some help please. Working on a 1720. I changed the fuel filter and had trouble starting. I cracked the injector lines at the injectors until flow. Cylinders 2 and 3 were good, now flow out of #3. It did start, no power due to running on 2 cylinders. I was hoping under pressure it would start flowing. All of a sudden a large “plug” of oil shot out the overflow. Immediately shutdown. So maybe running 2 minutes total . I checked the oil that was free flowing out the dipstick. Very water like and smells like fuel in the oil. I had just changed the oil too, ugh. Bad injector pump, clogged line, or what? Not sure where to start.

the old fuel filter was bad shape.

thanks in advance guys,,
 

·
Registered
Joined
·
10 Posts
I once have same problem, my problem I did check and do everything, except the fuel filter, . I put it in backward, turn the filter the other way, and it works fine, maybe you can try that little simple fix first
I guys, looking for some help please. Working on a 1720. I changed the fuel filter and had trouble starting. I cracked the injector lines at the injectors until flow. Cylinders 2 and 3 were good, now flow out of #3. It did start, no power due to running on 2 cylinders. I was hoping under pressure it would start flowing. All of a sudden a large “plug” of oil shot out the overflow. Immediately shutdown. So maybe running 2 minutes total . I checked the oil that was free flowing out the dipstick. Very water like and smells like fuel in the oil. I had just changed the oil too, ugh. Bad injector pump, clogged line, or what? Not sure where to start.

the old fuel filter was bad shape.

thanks in advance guys,,
 
1 - 9 of 9 Posts
Top