Ford 1210

Discussion in 'Repair & Technical Discussion' started by nopo hank, Sep 6, 2010.

  1. nopo hank

    nopo hank New Member

    2
    Sep 6, 2010
    Need advice. Just purchased a used Ford 1210; brought it home on a trailer. The tractor had been setting outside for a year and a half. i have dumped the old fuel; dumped filter bowl - have replaced with fresh diesel. I put in a new battery; the glow plug indicator and plugs are working. The tractor fires and runs for 2 seconds. Any suggestions on where to go next?:confused
     
  2. tractor beam

    tractor beam ENGLISH SPRINGER SPANIELS Staff Member

    Jan 25, 2010
    Priest River, Idaho
    Welcome to the forum Nopo Hank! Does it have a spin on filter, and has that been replaced? Have you bled the lines of old fuel, and additionally verified that the fuel pump is working? I'm not a diesel mechanic by any means, but thought I'd mention these things in the hopes it helps you out.
     

  3. BERMUDA KEN

    BERMUDA KEN New Member

    52
    Jul 23, 2010
    It sounds like there is air trapped in the system yet. Try loosening the bleeder screws and then cranking it over. If air bubbles appear, there is the issue.

    Also, since this has been parked for so long, pull the air cleaner out and see if it is packed full of dirt.
     
  4. nopo hank

    nopo hank New Member

    2
    Sep 6, 2010
    nopo hanks 1210 saga contnues

    started working on tractor again today with friends. removed injectors one seemed lose on removal. will take to diesel doctor for testing or rebuild. will keep the forum posted. we think this is the problem.:coffee: