Farm Pro 2420 hydraulics

Discussion in 'Chinese / Grey Market Tractors' started by bigcountry1009, Apr 7, 2007.

  1. bigcountry1009

    bigcountry1009 New Member

    24
    Apr 6, 2007
    The hydrolics on my little Farm Pro 2420 have slowly stopped working. At first, it would slowly let the mower down. That got progressively faster until finally it won't lift the mower at all. This happened over the period of a few weeks. I've checked the fluid. It was a little low and I added to it, but that didn't help. I've been told that most hydraulic systems have a filter, but I don't know where it might be. I would ask Farm Pro customer support, but I haven't had any luck getting through to them this week.

    Thanks
    Matthew
     
  2. mark777

    mark777 New Member

    518
    Jul 23, 2004
    Bigcountry, Welcome to TF!

    Nice to see a member representing the Chinese brand.

    Sorry I'm not familiar with your tractor but generally they have a spin on filter if the tractor has rear remotes and also a pick up screen inside the transmission...the screen is usually at the end of your larger steel hydraulic return line. Often this line is flanged and bolted to the side of the transmission reservoir.

    More often then not, slow, sluggish or sporadic hydraulics are clogged filter related.

    I am guessing on yours though :). Hope someone with more (and better) information pops in and helps you out.

    Mark
     

  3. bigcountry1009

    bigcountry1009 New Member

    24
    Apr 6, 2007
    Thanks for the welcome. Not only am I new to the thread. I'm new to tractors all together for the most part. First one I've ever owned. The Farm Pro tractors are made by Jinma, I just don't know which one this model is similar to. Thanks for the reply. I'm gonna check it over today. I found a Chinese Tractor forum a little bit ago, but you have to pay to be able to use it. I really can't see paying for a forum, although I did search past forums and I found that folks have had to replace everything from filters/screens to pumps and seals. We'll see what happens.
     
  4. Live Oak

    Live Oak New Member

    Dec 21, 2003
    Let me add my welcome to Tractor Forum as well bigcountry1009! Is your tractor a 2420 or 2520? Just checking in case there was a typo. Homier sells Farm Pro tractors and offers parts support. Below is a link to their website where you can contact them.

    Farm Pro

    If you can find some parts numbers and more info on your tractor, you can hopefully find parts here:

    Jinma Parts

    Chip Uren is one of our members. He goes by the username Artrac. He sells a variety of chinese import tractors. Hopefully he will see this thread and jump in with some great advice or you can PM him. His website is under construction right now. Here is the link for it anyway for when it is back online again.

    Artrac

    If your tractor is brand new and it sounds like it is. I would strongly recommend draining and replacing ALL of the fluids with good quality fluids if the OEM chinese fluids are still in it. They put very poor quality cheap fluids and filters in these tractors which in many cases causes these problems.

    Do you have an owners and repair manual for this tractor yet? You should order one ASAP. The chinese import tractors are a good buy for those who are able to keep up with the little bit more added maintenance of the more established brands. They all break and need TLC. Just have to learn how to give it. :D :thumbsup:
     
  5. mark777

    mark777 New Member

    518
    Jul 23, 2004
    Big,

    That's ridiculous. Right off the bat CTOA come to mind (www.ctoa.com) This is a free forum for Chinese Tractor Owners of America...hence CTOA.

    OK....I'm back from just visiting there as a guest. Searched your model number and "Slow Hydraulics". Excellent article concerning maintenance and problem solving issues...Plus the forum header says "Helping Each Other", You gotta' like that.

    If you go there, please come back and let us know what you find? Many of us are curious and willing to learn regardless of what model.

    Mark
     
  6. bigcountry1009

    bigcountry1009 New Member

    24
    Apr 6, 2007
    This is from The Chinese Tractor Owners Association www.ctoa.net

    Is this the site you visited? It says I can access "Buying a Chinese Tractor", but that's it without paying.

    Anyway, I have a 2420 model. I can't remember if the tag says it was built 01/03 or 03/01. I'll check in a bit. It got cold out here today. We did all the fluids ourselves when we got it. My dad has the ppr work, so I'm gonna ride out there and see what I can find.

    Thanks by the way. I need lots of help, and try to give some as well so I'm a member of many different forums for different things. This one has by far been one of the most friendly and courteous. Thanks folks, outstanding experience so far.

    Matt
     
  7. mark777

    mark777 New Member

    518
    Jul 23, 2004
    Yes...And quite frankly, I was shocked that they ask $15. to allow you to participate in the forum. I joined just to test the boundaries of a member who hasn't paid. I can view polls, search and view forum discussion ONLY.

    Had I known...I wouldn't have suggested it.

    Mark
     
  8. HYDROGUARDIAN16

    HYDROGUARDIAN16 LT/GT Moderator

    598
    Feb 13, 2007
    maybe air in lines but thats all i can think of
     
  9. bigcountry1009

    bigcountry1009 New Member

    24
    Apr 6, 2007
    Well, finally found all the ppr work for the 2420. I'll see what I can come up with.
     
  10. mark777

    mark777 New Member

    518
    Jul 23, 2004
    big,

    I did find that your return line is under you seat AND there is a hydraulic screen attached inside the reservoir that does clog occasionally.

    Mark
     
  11. chrpmaster

    chrpmaster New Member

    May 5, 2004
    Big

    I was curious how long you have had the tractor. Just a few weeks or longer? I am interested in your impression about this tractor since I have been looking at them for several years. The main distribution center is in Huntington Indiana which is only a 25 min drive from me. Much easier to get parts and tech help when you can walk in and not leave til you get an answer.:D

    Andy
     
  12. bigcountry1009

    bigcountry1009 New Member

    24
    Apr 6, 2007
    Got it last winter. All I did was winterize it. I did cut a little grass with it and realized the blades are shot. My uncle had it for 4 years. Only complaint he had was that he didn't go ahead and get the front end loader. But, there are many more on here with more experience. Try and post and find out what they think. But, so far, it appears to be a jam up tractor. From what I've heard and read on the net, if you're prepared for possibly a little more maintenance, you can't beat it.

    http://www.subgunner.com/FarmPro.htm
    http://www.johnstractor.homestead.com/

    try these 2 sites, might help too. Farm Pros are made by Jinma.

    Thanks Mark, I'm gonna get out there and wrench on it a little today. See what I can come up with. The manuals are very detailed, but the translation from Chinese is very bad in some parts. It also gives detailed instructions on how to do things, but leaves the precise location out, so i'll hunt for things that look like the drawings.

    Thanks guys
     
    Last edited: Apr 8, 2007
  13. bigcountry1009

    bigcountry1009 New Member

    24
    Apr 6, 2007
    More symptoms of problem

    Ok, finally got through to Farm Pro customer service. Talked to a nice fella named Jeff. Told him my symptoms, well, tractors symptoms. Said it sounded like the"scraper seals" and/or o-rings in the 3-points hyd. cylinder and began to go into a fairly simple sounding, but very detailed explanation of how to replace them. however, I have a few more details to give for you guys to check and be sure thats my problem before I go tearing into this thing.

    I took the mower off the tractor and tried to work the 3-p hitch, won't even move with no load on it.

    when I try to work it, it bogs the motor unless I've got the rev's up

    On the hitch, on the inside part of the housing where the lifting arms are attached to the cylinder (I assume), there are two flat head screws, and I noticed that hyd fluid is seeping out of them fairly profusely, especially when the 3-p is attempting to work.

    Also, the tractor has power steering which is driven from the same system, I found the diverter valve last night. It steers just peachy.

    I also found a hard steel line bolted to the top of the rear hyd. housing under the seat which I assume is the pressure line. There is an odd shaped 3 bolt flange holding it on. Is that where the filter screen may be?

    Thanks guys
     
  14. mark777

    mark777 New Member

    518
    Jul 23, 2004
    Re: More symptoms of problem


    Big Country,

    I sure wish I were more familiar with your model tractor. Just speaking in basic hydraulic tractor terms...your pump straining and needing additional RPM indicates (to me) some type of restriction and not seal failure. I believe the seals bypassing would cause "Creep" rising slowly or load failure - as in rapid drop of the 3PH hitch in the UP or neutral positions with implements attached.

    Just speaking in broad or generic terms but usually (most often) the small line at the pump is your high pressure line, and the large one is the return line (under the seat). The screen under the flange is exposed to hydraulic surges and will scavenge dirt and debris from constant agitation...JMHO but this is where I would start: Drain fluid, remove and clean reservoir screen at the return line, replace with fresh fluid and run tractor up to temperature. It could fix the problem, or at least eliminate the whole area and proceed to the 3PH seals and fittings.

    I've heard that the Chinese tractors 'shed' considerable amounts of internal sand castings and it may be a small piece interfering with the normal hydraulic operation ?? Have you heard any such likelihood?

    Again, good luck and keep us posted.

    Mark
     
  15. bigcountry1009

    bigcountry1009 New Member

    24
    Apr 6, 2007
    That's definitely what I was thinking of doing, start simple. It won't take much just to see if the screen is clogged. I need to replace the fluid anyway. And I can believe that anything from China would shed stuff. I'm pleased with the tractor, but come on, it's from a Communist country that doesn't have access to highest quality materials. Anyway, I'll try the simplest deal first, I've got to take it off anyway if the seals are bad.

    They Farm Pro guy also said that it might be lifting the mower too high, which shears the seals off. We haven't messed with anything since we've had it. He said we need to adjust the lever so it doesn't lift so hight, but I don't see how.
     
  16. ARTRAC

    ARTRAC New Member

    42
    Jan 6, 2004
    Hi, Matthew, Chip Uren from ARTRAC here. There is a plastic knob located below and in fron of the seat, there is also a small set screw that sometimes must be loosended before this knob will turn, but this knob restricts flow out of the 3 point lift cylinder to slow the speed the implement lowers. Be sure it is not closed tight. Next if your tractor will raise an implement, will it hold it up or does it fall down? If it raises but wont hold it up, it is usually the O ring and plastic wipers Jeff told you about. They fail if the 3 point is allowed to raise too much (controlled by a pair of jam nuts on the end of a rod connected to the operating lever that shuts the lever off when the lift gets high enough. These should be turned in a good half to 3/4 inch from the end of the rod. If they are at then end (some people move them to get more lift for post hole diggers) the piston can push out past the end of the cylinder (in the box under the seat) enough for the O ring and wipers to come out past the cylinder and when the lift is lowered, they get damaged when they are pushed back in to the cylinder.

    However if this is the problem, the lift will still raise, it just wont stay up. If it will not raise at all, there are other things to check, more later. Do you have power steering?
     
  17. bigcountry1009

    bigcountry1009 New Member

    24
    Apr 6, 2007
    Hey Chip, I think we've determined it is the o-ring and wipers. My dad had tightened the adjusting valve all the way down because our knob is broken off and he thought it was a fill plug of some sort, so it's lifting fine, just not holding up. I'm gonna get new seals and wipers for the 3-point and adjust the stop nuts in a bit more. Thanks anyway though.
     
  18. ARTRAC

    ARTRAC New Member

    42
    Jan 6, 2004
    No problem, good to see some Chinese tractor quesitons here. this is a good group of people, just don't ever have much to say here!
     
  19. bigcountry1009

    bigcountry1009 New Member

    24
    Apr 6, 2007
    Hey man, I'm satisfied with mine. I will mainly be mowing or tilling a garden with mine. And I can't afford the domestic brands at the moment. So, I've got to learn how to work on it to keep it ticking.
     
  20. bigcountry1009

    bigcountry1009 New Member

    24
    Apr 6, 2007
    Changed cylinder washers and it didn't help

    Hey folks, been gone a while. I see my post is still here. I changed the cylinder washers on my Farm Pro, but it didn't help my problem. Now I'm down to possibly changing the whole lift cylinder and piston or the 3-point valve assembly itself. Maybe rebuilding or replacing it. Feel kinda like chasing a rat at the moment. Any more suggestions?