You are Unregistered, please register to use all of the features of TractorForum.com    
Tractor Forum > General Tractor Forums > Repair & Technical Discussion > Ford TW20 Electric problems


Reply
 
LinkBack Thread Tools Display Modes
Old 04-20-2017, 05:34 PM   #1
etherks
Registered User
Feedback Score: 0 reviews
 
Join Date: Apr 2017
Posts: 1
Ford TW20 Electric problems

My Ford TW20 with all the lights discharges and kills battery. We've rebuild the alternator and installed a new voltage regulator. The battery is also only a year old.

Cannot figure out the discharge.


etherks is offline  
 
Reply With Quote Quick reply to this message
Old 04-21-2017, 04:19 AM   #2
RC Wells
Registered User
Feedback Score: 0 reviews
 
Join Date: Dec 2008
Posts: 402
Liked 174 Times on 128 Posts

Since it is light related, check the light switch for an internal ground created by corrosion. Also check the turn signals and the non-sealed beam running lights for dirt in the sockets. Dirt in the dash light sockets can also cause excessive current draw that is not enough to blow a fuse.

There is also an auxiliary power port on the back of the tractor, check that for dirt and corrosion.
RC Wells is offline  
 
Reply With Quote Quick reply to this message
Reply


Quick Reply
Message:
Options

Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
TW20 hydraulic issue Tw20guy Repair & Technical Discussion 0 04-02-2016 12:20 AM
Ford TW20 Possible Remote valve issue Tw20guy Ford / New Holland 0 04-01-2016 10:58 PM
JD 285 electric clutch problems JD285 John Deere 5 08-26-2014 04:31 PM
ford 3910 - electric scheme zemarinho Ford / New Holland 2 06-01-2013 09:12 AM